Michigan Tech Selected contributions from Michigan Technological University Tech Alive
  Tech Alive > Support Index > Create a Module - General Index > Contribute Interface
  About
  Series
  Services
  Support
  Contact

Tech Alive Support

Creating a Module - General: Contribute Interface

Home Page | Pages Panel | Choose | Preview | Saving | Mistakes

Home Page

Contribute Home PagesThe home page, start page, or index page (index.htm) is where you are taken when you launch Contribute using your Connection Key. There can only be one home page per key. If you have more than one module, you can edit pages in other modules by navigating to them in Browser mode. Return to the index page by clicking on the Home Pages button.

Pages Panel (Sidebar)

Sidebar
Sidebar (F4): Click to Expand Image.

Contribute has 2 modes: Browser Mode and Edit Mode. Web browsing is the default mode, and you can use Contribute to browse the web as you would with Netscape, Internet Explorer, or any other web browser. The Pages Panel, or Sidebar, can be accessed by doing View > Sidebar, by pressing F4, or by clicking the Expand/Collapse arrow.

Select "Browser" to navigate to other pages (if they are linked) or to access module pages directly by using "Choose" (if they are not linked). The browser "Back" button can be used. You can also type web locations directly into the Address field. You can also Bookmark your pages.

You edit pages by clicking the "Edit Page" or "New Page" buttons. The drafts will appear in the Pages Panel. You can have multiple drafts open. Select an open Draft (or New page) by clicking its name in the panel. You can only edit pages inside your module folders. Edit Mode is characterized by dotted lines where the layout table cells are located.

Macromedia provides online documentation, located at the bottom of the panel and in the Help menu. This is for general assistance only. For specific information about your module type, see Tech Alive Support Index.

Choose

Choose ButtonWhen web pages are linked together, you navigate between them by clicking on the web links. When they are not, click the "Choose" button to browse your module directory. You must be in Browser Mode to use the Choose button.

Preview

Edit Mode only gives you a rough idea of how your page will look. Press the F12 key to preview the page in your default browser. This page is temporary. No one will be able to see your changes online until you Publish.

In general, you do not need to resize layout table cells to make your content look good. Do a Preview first. The browser will wrap text and other elements and resize table cells as needed to optimize the layout.

Saving

  1. Ctrl+S: Temporary quick save.
  2. Save for Later button: For offline work. Saves a temporary copy on your computer. Contribute knows where this draft is located and can find it again automatically for upload later.
  3. Publish button: Permanent save. This action uploads your temporary files to the Tech Alive web server inside your module directory. It copies images to the "images" folder and documents to the "documents" folder inside your module directory. Publish uses FTP to transfer files. Don't interfere with this network activity until it is finished.

Mistakes

  1. Ctrl+Z: Or Edit > Undo. Use this to undo immediate changes in Edit Mode.
  2. File > Roll Back to Previous Version...: Contribute automatically saves the 3 previous published versions of each web page. Use this in Browser Mode to be presented with the rollback versions listed by date.

Return to Top